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Outline
• Introduction to NGS data analysis pipeline 

• Quality check 
• Alignment 
• Higher level analysis (peak calling) 
• File formats 

• Visualization of NGS data using IGV 
• RNA-seq, ChIP-seq, … 
• IGV tools 

• Practice
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Next Generation Sequencing
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• Read the bases of a DNA/RNA sequence 
• Applications 

• Sequence DNA of known or unknown organism 
• Detect variants on patients 
• Sequence the RNA of a cell 
• Detect location of proteins interacting with DNA 

• Problem 
• Only short DNA sequences ( < 1000 bps) can be read 

• Solution 
• Bioinformatics

Sequencing



010110110101
101001001010

Institute for  
Computational Genomics

Information Level vs. NGS

DNA

RNA

Proteins

genetic information 
 level

DNA Sequencing 
-> detection of  genetic variants 
-> de-novo reconstructions of genomes
RNA Sequencing 
-> quantification of RNA in a cell 
-> de-novo identification of RNAs

Detection of Interactions: 
•  ChIP Sequencing -> a protein with DNA 
•  CLIP Sequencing -> a protein with RNA 
•  ChIRP Sequencing -> a RNA with DNA 
• … 
      See here for a comprehensive list of Seq essays (>50) 

https://liorpachter.wordpress.com/seq/
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Next Generation Sequencing
! NGS take advantage of parallelization  

! reads millions/billions of reads for a time 
! shorter reads (50-100 bps) 
! higher error rates (0.1-1%)   

! commercial products: 
! 454 
! SOLiD 
! Solexa (Illumina) 
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Next Generation Sequencing
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Next Generation Sequencing

Jay Shendure, et al (2017), Nature
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Read Types
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Read Types

Advantages:  
- cheaper 
 -compatible with protocols 
producing small fragments 
(Ribo-seq, mirRNA-seq) 
                  
               

Advantages:  
- easier to align 
 -helps detection of variants 
(DNA), exon pairs (RNA)  
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FASTA files

>dnaA chromosomal replication initiator protein DnaA 
MSLSLWQQCLARLQDELPATEFSMWIRPLQAELSDNTLALYAPNRFVLDW
VRDKYLEALRDLLALQEKLVTIDNIQKTVAEYYKIKVADLLSKRRSRSVARP
RQMAMALAKELLHAVGNGIMARKPNAKVVYMHSERFVQDMVKALQNNAI
EEFKRYYRSVDALLIDDFSLPEIGDAFGGRDHTTVLHACRKIEQLREESHD
KEDFSNLIRTLSS
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FASTA files

>dnaA chromosomal replication initiator protein DnaA 
MSLSLWQQCLARLQDELPATEFSMWIRPLQAELSDNTLALYAPNRFVLDW
VRDKYLEALRDLLALQEKLVTIDNIQKTVAEYYKIKVADLLSKRRSRSVARP
RQMAMALAKELLHAVGNGIMARKPNAKVVYMHSERFVQDMVKALQNNAI
EEFKRYYRSVDALLIDDFSLPEIGDAFGGRDHTTVLHACRKIEQLREESHD
KEDFSNLIRTLSS

Start symbol Sequence ID 
(no spaces) Sequence description 

(spaces allowed)

The sequence
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FASTQ files

https://en.wikipedia.org/wiki/Phred_quality_score
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FASTQ files

Uses letters/symbols to represent numbers:

!"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJ

Q0 Q10 Q20 Q30 Q40 

bad maybe ok good excellent 
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Bioinformatics Analysis in R 

Next Generation Sequencing 
Data Analysis
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Pre-processing
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• Sequencing and sample preparation introduce 
errors 
• Errors in start/end of reads  
• Bases bias on read positions 
• Presence of adapter sequences  
• Fragment duplication from PCR 
• … 

• Tools: FastQC (for checking), Trimmomatic (for 
trimming), …

Pre-processing
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• FastQC (usually provided by NGS core facilities)  
•  tool to analyse quality of reads from sequencing. 
• indicate problems in library preparation or sequencing 

steps.  
• Example of good sequences: 

• http://www.bioinformatics.babraham.ac.uk/projects/
fastqc/good_sequence_short_fastqc.html 

• or bad sequences: 
• http://www.bioinformatics.babraham.ac.uk/projects/

fastqc/bad_sequence_fastqc.html

http://www.bioinformatics.babraham.ac.uk/projects/fastqc/

Quality Control

http://www.bioinformatics.babraham.ac.uk/projects/fastqc/good_sequence_short_fastqc.html
http://www.bioinformatics.babraham.ac.uk/projects/fastqc/good_sequence_short_fastqc.html
http://www.bioinformatics.babraham.ac.uk/projects/fastqc/bad_sequence_fastqc.html
http://www.bioinformatics.babraham.ac.uk/projects/fastqc/bad_sequence_fastqc.html
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http://www.bioinformatics.babraham.ac.uk/projects/fastqc/

Sequencing quality decreases with size.

Quality Control

Solution: trim end of reads with low quality
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Read position sequence bias

• Trim read starts
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http://www.bioinformatics.babraham.ac.uk/projects/fastqc/

Sequence duplication levels

Quality Control

• Solution: remove duplicates
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(Short reads) Alignment
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Short Read Alignment
• Query 

• sequenced reads in FASTQ format 

• huge number of them, 1M ~ 100M 

• short read length, ~100 bp 

• Reference 

• human genome in FASTQ format 

• total size ~3 billion bps 

• Lots of short vs. a few longs 

• BLAST would take several years to run. 
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Pitfals

- (Unknown) divergence of sample and reference 
genome 
- Poor genome reference quality 
- Repeats in the genome (larger than read size) 
- Recombinations 
- Sequencing/read errors 
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Algorithms - Alignment

Short read alignment is a special problem 
• reference sequence (genome) is large and fixed 
• query sequence (reads) are short and many 
Solution:  
1. Pre-process the genome finding all exact alignments for 
small sequences (>14bps) (index) 

• k-mer hash table (>10GB) 
• compressed suffix trees (> 4GB)  

2. Break your read in small pieces (>14bps) and extend 
your alignment on all candidate positions using dynamic 
programming.  
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Alignment Tools

https://www.ecseq.com/support/ngs/what-is-the-best-ngs-alignment-software
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Reference based aligners -  Overview

Memory Application (Comments)

BOWTIE + + - - 5GB General  
(max. 3 missmatches)

BWA + + + + 8GB General  
(max of 200bps reads) 

NOVOALIGN + + + + 8GB General  
(commercial license) 

STAR + + - + 32GB RNA-Seq  
(allow split-maps)

BISMARK + + + + 10GB Bisulfite/reduced 
sequencing

Ti
m

e
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ec

is
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n
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irs

G
A

Ps

Ph
re

d

non comprehensive list
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Alignment Tools

https://www.ecseq.com/support/benchmark
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SAM Files

• Store alignment results as text-based file 
• Consists of a header and an alignment section

Header

Alignment
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SAM Files- alignment section

• SAM files will have large size (1-10 Gbs) 
• Usually a experiment has dozens of such files 

• BAM files (zipped version of SAM) is more common and reduces 
the size by 30-50%. This file can be opened in genome browsers if 
a index file is also given. 



Applications - Variant Calling 

http://en.wikipedia.org/wiki/RNA-Seq 



Example Application

SNP Detection - Individual DNA Sequencing 

          Alignment of short reads on DNA



SNP Calling Example - Genome Browser

IGV only show miss-matches!



Simple SNP Calling Method
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Applications - Peak Calling

http://en.wikipedia.org/wiki/RNA-Seq 

Peak Calling 
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ChIP-Seq - Data Files

gene A

H3K4me3 (active region)

Transcription factor 1
Transcription factor 2

Nucleosome

H3K4me3 antibody

gene B

Reads

Signals

Peaks

sam/bam 
 files

bw/tdf files

bed files
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Peaks - Bed files

chr7 127471196 127472363 Peak1 0 +  

chr7 127472363 127473530 Peak2 0 +  
chr7 127473530 127474697 Peak3 0 +  

chr7 127474697 127475864 Peak4 0 +  

chr7 127475864 127477031 Peak5  0 -  

chr7 127477031 127478198 Peak6  0 -  
chr7 127478198 127479365 Peak7  0 -  

chr7 127479365 127480532 Peak8 0 +  

chr7 127480532 127481699 Peak9 0 -  

Chromosome
Start End Name Score

Strand

• Peaks / genomic regions are stored in bed files
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Genomic Signals - WIG/TDF Files

variableStep chrom=chr1
140000 30.5
140100 25.1
141200 14
142000 -32.8

Genomic
Coordinate

Signal

Header Chromosome

• Files containing smoothed counts of reads for ChIP-seq, 
RNA-seq, or similar protocols.

• Example of WIG file

• In practice, we use binary version of WIG 
(BIGWIG) or TDF files
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Bioinformatics Analysis in R 

Next Generation Sequencing 
Data Visualization
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IGV (Integrative Genome Viewer)

• Desktop application for the visual interactive exploration 
of integrated genomic datasets 

James. T, et al (2011), Nature Biotechnology
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Advantages

• A high-performance visualization tool 
• Allows us interactively explore large, integrated dataset 
• Supports a wide variety of data types, including 

microarray and next-generation sequencing data 
• FREE
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Launch IGV
http://software.broadinstitute.org/software/igv/home

http://software.broadinstitute.org/software/igv/home
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Launch IGV
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Launch IGV

Select genome from the  
drop-down menu
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Launch IGV

1
2

3

4

Sample information

Genome navigation

Data

Genome locations and sequence
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Viewing NGS Data

Load data from the  
ENCODE project
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search CTCF and GM12878

Viewing NGS Data
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sort by lab

Viewing NGS Data
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select alignments, signal and peaks

load data

Viewing NGS Data
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Peaks / bed fileSignal / wig/tdf file

Viewing NGS Data

Alignmetns / BAM file
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File Formats

• The file format defines the track type 
• The track type determines the display options 
• IGV supports many file formats

• BAM 
• BED 
• BedGraph 
• bigBed 
• bigWig 
• Birdsuite Files 
• broadPeaks 
• CBS 
• CN 
• Cufflinks Files 
• FASTA

• GCT 
• genePred 
• GFF 
• GISTIC 
• Goby 
• GWAS 
• IGV 
• LOH 
• MAF 
• MUT 
• narrowPeaks

• PSL 
• RES 
• SAM 
• SEG 
• SNP 
• TAB 
• TDF 
• TrackLine 
• TypeLine 
• VCF 
• WIG

http://software.broadinstitute.org/software/igv/FileFormats
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File Formats

Note: for large files use indexed formats 
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Hands on

• Lunch IGV on your computer 
• Choose human genome hg19 
• Load data from ENCODE project 

• ChIP-seq of factor CTCF for GM12878 cell type 
• Alignments, peaks and signal
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Navigation

Chromosomes
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Navigation

Select chromosome
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Navigation

chromosome 1

genes
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Navigation

double click a specific region to zoom in



010110110101
101001001010

Institute for  
Computational Genomics

Navigation

Click + to zoom in, - to zoom out
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Navigation

Type gene name or other annotation  
into RefSeq Genes and click Go
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Customize your track

Navigation



010110110101
101001001010

Institute for  
Computational Genomics

Input multiple regions
Viewing multiple regions
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Viewing multiple regions

Click Regions >Region Navigator

Click add

Repeat above step to add more regions
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Viewing multiple regions

Select two or more regions 
click View
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Hands on

• Change the color of CTCF track 
• Find more than two interesting regions 
• View the multiple regions 
• Load more dataset from ENCODE project 

• H3K4me1 of GM12878 
• H3K4me3 of GM12878 

• Use different color for these three tracks
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IGV Tools

• toTDF 
• Converts sorted data file to binary file (TDF). 

• counts 
• Computes average alignment or feature over a 

window size across the genome 
• sort 

• Sorts file by genomic position 
• index 

• Creates an index file for alignment or feature file 

A set of utilities for preparing files for efficient display
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IGV Tools

Can be lunched from  
the IGV user interface  
Tools > Run igvtools…
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toTDF
The toTDF utility converts large data files into tiled data 
format  (.tdf) files

TDF files have the following advantages: 
• Data is indexed for efficient retrieval 
• Data is preprocessed for zoomed out views 
• TDF files are web friendly - large data can be shared 

over the web.
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count
The count command is used to transform alignment files 
to read density TDF files, e.g. for ChIP-seq, RNA-seq and 
similar alignment counting experiments

count

Alignment Read Density
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Find Motif
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Find Motif
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Find Motif

Track name



010110110101
101001001010

Institute for  
Computational Genomics

• Download data: 
• https://costalab.ukaachen.de/open_data/

Bioinformatics_Analysis_in_R_2019/BIAR_D5/
igvData.tar.gz 

• Create a new session

Viewing SNPs

Click New Session

https://costalab.ukaachen.de/open_data/Bioinformatics_Analysis_in_R_2019/BIAR_D5/igvData.tar.gz
https://costalab.ukaachen.de/open_data/Bioinformatics_Analysis_in_R_2019/BIAR_D5/igvData.tar.gz
https://costalab.ukaachen.de/open_data/Bioinformatics_Analysis_in_R_2019/BIAR_D5/igvData.tar.gz
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Viewing SNPs

• Load reference genome:

Click Genomes > Load Genome from File

Select chr1.fasta and refSeq_chr1.bed
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Viewing SNPs

• Load sequencing data:

Click File > Load Genome from File

Select snp_call,bed andNA12878.SLX.sample.bam
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Viewing SNPs

SNPs
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Viewing SNPs

Input snp1 and Click Go

a SNP with C -> T
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Viewing SNPs

Input snp1 and Click Go

Click here to see statistics
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Viewing RNA-seq data
• Create a new session

Click New Session

• Choose hg19 as reference genome

Click drop-down list and select hg19
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Viewing RNA-seq data

• Set preference for viewing RNA-seq data

Click View > Preference

Select Alignments tab 
Check junction track
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Viewing RNA-seq data

• Load data

Click File > Load from Server

Open Tutorial 
Click on RNA-seq > OK
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Viewing RNA-seq data

• Jump to your favorite gene
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Viewing RNA-seq data

Coverage

Junction

Alignment



Split Read Mapping (RNA-Seq)

• Reads spanning distinct exons indicate junctions

Exon A Exon B Exon C
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Viewing RNA-seq data

Coverage

Junction

Alignment

• Example of alternative splicing 
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Viewing RNA-seq data

Coverage

Junction

Alignment

• Example of alternative splicing 

Right click and select Squished
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Viewing RNA-seq data

Coverage

Junction

Alignment

• Example of alternative splicing 

Alternative splicing
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• Example of alternative splicing 

Viewing RNA-seq data

Right click Junction > Sashimi plot
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• Example of alternative splicing 

Viewing RNA-seq data
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